Workato Platform Performance Degradation

Incident Report for Workato EMEA

Resolved

After further monitoring, this issue is now resolved, and customers can successfully access recipe job histories. Please contact Workato Support (https://support.workato.com) or your assigned CSM if you have any questions or require assistance regarding this event.
Posted Apr 07, 2026 - 17:16 CEST

Monitoring

Our team has taken steps to remediate the issue and is seeing improvement. We are continuing to monitor the platform as it recovers.
Posted Apr 07, 2026 - 16:52 CEST

Identified

We are currently investigating an issue affecting the Job History dashboard. Customers may have noticed missing entries in the Job History table while navigating the Jobs tab. We will share additional information as soon as it is available.
Posted Apr 07, 2026 - 14:57 CEST
This incident affected: Workato Orchestrate (Workspace UI).