VUA app connections failing for MCP and Genies

Incident Report for Workato EMEA

Resolved

The issue has been resolved and customers should now be able to use VUA to establish connections for MCP servers and Genies. If you continue to experience any issues, please contact Workato Support at https://support.workato.com.
Posted Mar 27, 2026 - 01:01 CET

Identified

We have identified the underlying cause of an issue impacting Verified User Access (VUA) app connections and are actively working on remediation. Customers may encounter a "Failed to establish connection" error when attempting to connect apps (such as Google Drive, Gmail, Salesforce, or other OAuth-based connectors) through MCP servers or Genies using Verified User Access. We will share additional information as soon as it is available.
Posted Mar 27, 2026 - 00:33 CET